Commit 0b86cdc1 authored by Anton's avatar Anton

Update mbjs-generic-api module, patch release bump

parent 7da0b198
......@@ -9,6 +9,12 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
No changes.
## [1.2.1] - 2019-02-21
### Changed
- Updated [mbjs-generic-api](https://gitlab.rlp.net/motionbank/mbjs/generic-api) to version 0.8.3
## [1.2.0] - 2019-02-17
### Added
......@@ -49,7 +55,8 @@ No changes.
- Start proper versioning at 1.0.0
[Unreleased]: https://gitlab.rlp.net/motionbank/api/compare/v1.1.0...master
[Unreleased]: https://gitlab.rlp.net/motionbank/api/compare/v1.2.1...master
[1.2.0]: https://gitlab.rlp.net/motionbank/api/compare/v1.2.0...v1.2.1
[1.2.0]: https://gitlab.rlp.net/motionbank/api/compare/v1.1.0...v1.2.0
[1.1.0]: https://gitlab.rlp.net/motionbank/api/compare/v1.0.0...v1.1.0
[1.0.0]: https://gitlab.rlp.net/motionbank/api/compare/initial...v1.0.0
{
"name": "api",
"version": "1.2.0",
"version": "1.2.1",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......@@ -1040,9 +1040,9 @@
}
},
"ecdsa-sig-formatter": {
"version": "1.0.10",
"resolved": "https://registry.npmjs.org/ecdsa-sig-formatter/-/ecdsa-sig-formatter-1.0.10.tgz",
"integrity": "sha1-HFlQAPBKiJffuFAAiSoPTDOvhsM=",
"version": "1.0.11",
"resolved": "https://registry.npmjs.org/ecdsa-sig-formatter/-/ecdsa-sig-formatter-1.0.11.tgz",
"integrity": "sha512-nagl3RYrbNv6kQkeJIpt6NJZy8twLB/2vtz6yN9Z4vRKHN4/QZJIEbqohALSgwKdnksuY3k5Addp5lg8sVoVcQ==",
"requires": {
"safe-buffer": "^5.0.1"
}
......@@ -1929,11 +1929,11 @@
}
},
"jsonwebtoken": {
"version": "8.4.0",
"resolved": "https://registry.npmjs.org/jsonwebtoken/-/jsonwebtoken-8.4.0.tgz",
"integrity": "sha512-coyXjRTCy0pw5WYBpMvWOMN+Kjaik2MwTUIq9cna/W7NpO9E+iYbumZONAz3hcr+tXFJECoQVrtmIoC3Oz0gvg==",
"version": "8.5.0",
"resolved": "https://registry.npmjs.org/jsonwebtoken/-/jsonwebtoken-8.5.0.tgz",
"integrity": "sha512-IqEycp0znWHNA11TpYi77bVgyBO/pGESDh7Ajhas+u0ttkGkKYIIAjniL4Bw5+oVejVF+SYkaI7XKfwCCyeTuA==",
"requires": {
"jws": "^3.1.5",
"jws": "^3.2.1",
"lodash.includes": "^4.3.0",
"lodash.isboolean": "^3.0.3",
"lodash.isinteger": "^4.0.4",
......@@ -1941,13 +1941,19 @@
"lodash.isplainobject": "^4.0.6",
"lodash.isstring": "^4.0.1",
"lodash.once": "^4.0.0",
"ms": "^2.1.1"
"ms": "^2.1.1",
"semver": "^5.6.0"
},
"dependencies": {
"ms": {
"version": "2.1.1",
"resolved": "https://registry.npmjs.org/ms/-/ms-2.1.1.tgz",
"integrity": "sha512-tgp+dl5cGk28utYktBsrFqA7HKgrhgPsg6Z/EfhWI4gl1Hwq8B/GmY/0oXZ6nF8hDVesS/FpnYaD/kOWhYQvyg=="
},
"semver": {
"version": "5.6.0",
"resolved": "https://registry.npmjs.org/semver/-/semver-5.6.0.tgz",
"integrity": "sha512-RS9R6R35NYgQn++fkDWaOmqGoj4Ek9gGs+DPxNUZKuwE183xjJroKvyo1IzVFeXvUrvmALy6FWD5xrdJT25gMg=="
}
}
},
......@@ -1963,12 +1969,12 @@
}
},
"jwa": {
"version": "1.2.0",
"resolved": "https://registry.npmjs.org/jwa/-/jwa-1.2.0.tgz",
"integrity": "sha512-Grku9ZST5NNQ3hqNUodSkDfEBqAmGA1R8yiyPHOnLzEKI0GaCQC/XhFmsheXYuXzFQJdILbh+lYBiliqG5R/Vg==",
"version": "1.3.0",
"resolved": "https://registry.npmjs.org/jwa/-/jwa-1.3.0.tgz",
"integrity": "sha512-SxObIyzv9a6MYuZYaSN6DhSm9j3+qkokwvCB0/OTSV5ylPq1wUQiygZQcHT5Qlux0I5kmISx3J86TxKhuefItg==",
"requires": {
"buffer-equal-constant-time": "1.0.1",
"ecdsa-sig-formatter": "1.0.10",
"ecdsa-sig-formatter": "1.0.11",
"safe-buffer": "^5.0.1"
}
},
......@@ -2231,9 +2237,9 @@
}
},
"mbjs-generic-api": {
"version": "0.8.2",
"resolved": "https://registry.npmjs.org/mbjs-generic-api/-/mbjs-generic-api-0.8.2.tgz",
"integrity": "sha512-C2p8bcUFqoph18KVf7wpwyb1sqUIZVq6vVyxhybqYEnomO7hAGKaE1wrgBAVZvYPBqfyMyzcjjg2KEO+VAKJRw==",
"version": "0.8.3",
"resolved": "https://registry.npmjs.org/mbjs-generic-api/-/mbjs-generic-api-0.8.3.tgz",
"integrity": "sha512-A20+7nzEsdGTp9Uac0JUjufP9cwZ115r63oNZf+LZIJ3+FV8kiUhZZ/TJNh88PEygsSSJiPYm8Ivc19YZ7iBaw==",
"requires": {
"@polka/send-type": "^0.4.0",
"acl": "^0.4.11",
......
{
"name": "api",
"version": "1.2.0",
"version": "1.2.1",
"description": "API server for Motion Bank Systems",
"main": "src/index.js",
"scripts": {
......@@ -44,7 +44,7 @@
"config": "^2.0.1",
"luxon": "^1.3.3",
"mbjs-data-models": "0.0.10",
"mbjs-generic-api": "0.8.2",
"mbjs-generic-api": "0.8.3",
"mbjs-persistence": "1.0.0",
"mbjs-utils": "0.0.6",
"minio": "^7.0.1",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment