Commit d1b8860e authored by Anton's avatar Anton

Add sentry vue integration, patch version bump

parent 984c5846
This diff is collapsed.
{
"name": "motionbank-systems-frontend",
"version": "1.3.6",
"version": "1.3.7",
"description": "Combined frontend project for Motion Bank web services",
"productName": "Motion Bank Systems Frontend",
"cordovaId": "org.motionbank.frontend",
......@@ -33,6 +33,8 @@
]
},
"dependencies": {
"@sentry/browser": "^5.9.0",
"@sentry/integrations": "^5.8.0",
"auth0-js": "9.8.2",
"axios": "0.18.0",
"bluebird": "3.5.3",
......
......@@ -4,6 +4,7 @@ module.exports = function (ctx) {
return {
// app plugins (/src/plugins)
plugins: [
'sentry',
'raven',
'api',
'auth',
......
import * as Sentry from '@sentry/browser'
import * as Integrations from '@sentry/integrations'
export default ({ Vue }) => {
if (process.env.SENTRY_DSN) {
Sentry.init({
dsn: process.env.SENTRY_DSN,
integrations: [new Integrations.Vue({Vue, attachProps: true})]
})
}
}
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment